Information Courtesy of Microsoft Knowledge Base Articles: 330163 and 329441
SYMPTOMS
When you try to create a new network connection, you may receive the following error message:
Error 711: Cannot load Remote Access Service Connection Manager.
The Routing and Remote Access service terminated with service-specific error 711 (0x2C7)
Incoming Connections depend on the Routing and Remote Access service which was unable to start. For more information, check the system event log.
You may also be unable to install network adapters.
CAUSE
This issue may occur if the following services are disabled:
- Telephony
- Remote Access Connection Manager
- Remote Access Auto Connection Manager
RESOLUTION
To resolve this issue, enable the disabled services, and then start the services:
- Click Start, right-click My Computer, and then click Manage.
- Double-click Services and Applications, and then double-click Services.
- Right-click Telephony, and then click Properties.
- On the General tab, click Manual next to Startup type.
- On the General tab, click Start under Service status, and then click OK.
- Repeat steps 3 - 5 for Remote Access Connection Manager and Remote Access Auto Connection Manager.*
- If, when you try to start the Remote Access Connection Manager service, you receive the following error message, keep going, if not, then this is the end of the fix:
Could not start the Remote Access Connection Manager service on Local Computer.
Error 5: Access is denied
NOTE: You receive this error message although you are logged on with an account that has administrative privileges.
CAUSE
This problem occurs because the System registry hive is not correctly restored to the Windows registry after you restore Windows.
RESOLUTION
To resolve this problem, reinstall SP1 for Windows XP.
WORKAROUND
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
If you cannot reinstall SP1, verify that the
Objectname string value is set to
LocalSystem in the following registry subkey:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesRasMan
After you do so, delete the following registry subkeys. The presence of these subkeys on a Windows XP-based computer that does not have SP1installed can cause the symptoms described earlier:
To delete these keys, follow these steps.
Note This procedure includes steps to make a backup of the registry keys before you modify them.
- Click Start, and then click Run.
- In the Open box, type regedit, and then click OK.
- Locate and then click the following key in the registry:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesRasMan
- On the File menu, click Export.
- In the File Name box, type exported rasman key, and then click Save.
- In the RasMan key, locate and then click the ObjectName string value.
If this value is not set to LocalSystem, follow these steps:
- On the Edit menu, click Modify.
- In the Value data box, type LocalSystem, and then click OK.
- Locate and then double-click the following key in the registry:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesRasManPPPEAP25
- On the Edit menu, click Delete.
- Click Yes to confirm that you want to delete the selected registry key.
- Repeat steps 7 to 9 to delete the following registry key:
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesRasManPPPEAP26
- Quit registry editor, and then restart your computer.